Author Topic: IOX024 Pulsing/Flashing Outputs  (Read 17 times)

Offline Lukey

  • PLUS+1 Novice
  • *
  • Posts: 4
  • Karma: +0/-0
IOX024 Pulsing/Flashing Outputs
« on: March 18, 2023, 04:05:35 PM »
Heyllo I am having issues with Pulsing/Flashing outputs in my application.

Hardware comprises of a DM430E and IOX024.

I have a simple PI loop circuit, a 0.5-4.5V pressure switch on C1p10 is functioning correctly, the signal input is reading steady.
But my PWM output C2p03 to the coil is turning on and off at approximately 3hZ.

I have checked my code to ensure no funny business, changes the PWM frequency on the group from my desired 160 back to 4000hZ but nothing.

I've even tested all the other outputs as PWM and/or Digital Outs in all possible PinConfigs and I am getting the same on and off at 3hZ.

CAN comms issue I have checked that and no errors there, I believe I can rule that out.

Does anyone have any ideas? I assume this hardware config (DM430E and IOX024 is proven/compatible)?

Offline FluidPowerTom

  • PLUS+1 Guru
  • *****
  • Posts: 328
  • Karma: +24/-0
Re: IOX024 Pulsing/Flashing Outputs
« Reply #1 on: Today at 04:34:07 PM »
If you put a checkpoint on the PI loop output is that reading steady?  If not then I guess post your PI loop logic here.

If so then are the repetition times and timeout time settings for your I/O module all set to default, or might something be off?  See attached for the default settings.
Mechanical Engineer
Hydra-Power Systems - Distributor - Pacific Northwest