PLUS+1 Hardware > I/O Modules

Issue in enabling hardware pin at connector 1

<< < (4/5) > >>

Apologies if this appears twice, I already tried to post this and got an error. The previous post does not show in the main topic but when I click reply it is showing in the topic summary.

When you tried Recover ECU did you select First ECU found or did you select Specify ECU and enter 0 for Net and 28 for Node?

Did you check that, as Tor suggested, you do not have the same node ID set for the primary and secondary? In the program for the primary under Unit_config what is the secondary node set to? The attached screen shot shows the unaltered template configuration of 27 for primary and 28 for secondary. Can't get the attachment to work today for some reason!

Were you able to confirm that there is not another device on the CAN bus with using Node ID 28?

Hi Acmall and Tor,

Thanks for your message

Now I can see 0, 28 option in ECU list.

So I flashed a new program without any changes into it and I can see both option (0, 27) and (0, 28). Still even I flashed both program, I can not see any output at pin 34 and 46. (I set the Digout to "True" before flashing it).

I investigated little more and the behavior of yellow LED is constantly HIGH. Even after flashing both the controller. I read it that it means it is "activated for Safety layer in error conditions"
No RED LED so it means no CAN fault. I think LED should be in GREEN mode then it should work correctly. (Correct me if I am wrong). Any help how to resolve those error conditions?

For the other devices connection, no its just Danfoss controller connected with the power supply. No other connection.

"For the attachment issue, I feel that the image size should not be large enough. If it is, page does not refresh and actual message failed to post.


Now that the secondary is showing up check and make sure that the secondary program has definitely downloaded successfully. From memory you also get solid yellow if there is no secondary program loaded. You can also add a log in the service tool for SafetyLayer.Failure.

For an additional test the attached zip contains tested programs for the primary & secondary that turn outputs 34 & 46 on for 2 seconds then off for 2 seconds. The included service tool shows the state of the digital outputs on an oscilloscope component.

Hi Acmall,

Thank you for your help and your program

Finally resolved the issue and can see output at Hardware pin. I created new project for secondary controller by selecting "secondary version" in hardware list.

Earlier I tried the same thing but I choose incorrect BAUD rate. By default it is set to 250K but in our project it was 500K.

Also the behavior of LED changed from YELLOW to GREEN.

Thank you @Acmall and @Tor for your valuable feedback and support. :)


Great job ShaswatD and acmall for solving this.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version