Author Topic: Compile error in 2024.1.3  (Read 2773 times)

Offline Egholm-Jonas

  • PLUS+1 User
  • **
  • Posts: 5
  • Karma: +1/-0
Compile error in 2024.1.3
« on: February 23, 2024, 09:42:30 AM »
I see there is some issues with compiling. But only for the display users so far!?
I can't compile on the MC088 either!

On the "error/Warning/Hint messages" tab after 3 seconds of compiling, it shows:
"Completed

 No specific issues identified"

But, on the Build message tab:

"Graphical Compilation and Linking of VCU_SOFTWARE_2XXXX aborted with errors
WARNING: invalid character '0xBB'
WARNING: invalid character '0xBF'
WARNING: invalid character '0xBB'
ERROR: MKFILE11.mak: line 1: needs an operator
?#
^
ERROR: #0210 - 1 error(s) occured while parsing the makefile

Offline Camox

  • PLUS+1 Developer
  • ***
  • Posts: 39
  • Karma: +3/-0
Re: Compile error in 2024.1.3
« Reply #1 on: February 26, 2024, 11:09:17 AM »
Hi, there,
What changes did you make after the previous compilation?
Do you have a backup with the 2023 version of the Guide?

Have a nice day!

Offline Egholm-Jonas

  • PLUS+1 User
  • **
  • Posts: 5
  • Karma: +1/-0
Re: Compile error in 2024.1.3
« Reply #2 on: February 26, 2024, 11:38:22 AM »
Hi Camox,

Nothing out of the ordinary!
Except updating to the new Guide 2024.1.3

Yes, I have a 1 month old backup! :'(

If I create a new Application, I does the exact same!

Offline acmall

  • PLUS+1 Guru
  • *****
  • Posts: 191
  • Karma: +36/-1
Re: Compile error in 2024.1.3
« Reply #3 on: February 26, 2024, 12:03:55 PM »
I just did a test on two projects, one using a DP720 and the other MC088-015. Both complied without issues and appear to be producing working programs on a bench test.

It would be good to find out what is causing this issue for some uses. For reference the HWD files for the programs I tested are: -
MC088-015 = V200
DP720 = tested with booth V260 & V270.


Offline Egholm-Jonas

  • PLUS+1 User
  • **
  • Posts: 5
  • Karma: +1/-0
Re: Compile error in 2024.1.3
« Reply #4 on: February 28, 2024, 01:32:21 PM »
With some help from Tor, I can move on again!! :)

The invalid character '0xBB" error was caused by the checkmark in "Regions Settings" on my pc. (See attached picture)

Why this was selected I have no idea! But this did it for me! :)