PLUS+1 Software > Communication

PVED-CC float position

(1/3) > >>

I have a PVG32 with PVED-CC coils, some of which have a floating position. However I'm having a hard time in making them reach the float position. I'm using a simple Tx block to send control data, where the address is the coil's ID, 1st byte is the spool position value and 3rd byte is the direction (1 or 2 for moving forward and backwards). The thing is that as the floating position is actually achieved at the cost of maximum spool's position in one direction I was told to simply force the spool into this position (say BYTE1:250 and BYTE3:1) and it should do the trick. But it doesn’t. I've read through the manual and it says that there is a special position for float. It's value is 3. But It's not responding if I sent 3 through BYTE3. I've tried using CANKing to get the response from the coil when I move it manually. I can see that the spool is physically capable of reaching the float position. I get the values and direction at which this is achieved but when I send those data I get nothing. I've always been using this method of steering the PVED-CC and it worked well so far. But it fails now. Could someone help me out? I'd appreciate any suggestions. Maybe there's a special block for PVED-CC coils? I'll take a look at the SD download page.


Hi Rafa.

Have you mechanically checked the spool moves the full 7mm, ie spool adjusters are not restricting movement?

regards Neil.

Also try byte 2,3?

KR Neil

I've already done that. I've checked to see if the spool is physically capable of achieving the float position (the hydraulic actuator is getting 'numb' when in float), and I've tried sending different data on Byte 3. As the datasheet sais, Byte 2 is reserved. I don't know for what but I got the impression that it should have a '0' value. And so this leaves me with Byte 2 as the 'valve state' data. I'm sending 1 or 2 (decimal) to retract or extend the spool. But sending 3 basically does nothing. How do I know? Well each movement of the spool is being represented by a green LED. Each time the coil is in warning or energy saving mode (basically does nothing) it goes to an orange LED. Well..... when I send '3' (still decimal) the LED does not change from orange. I've tried sending Byte1: 0 Byte 3:3, and Byte1:250 Byte 3:3. None of which does anything. I'm totally at a loss here. Don't know what to do especially as I can mechanically move the spool to the float position.

I'd really, really use some help. I'm nearing a deadline when I should get this bloody spool to move where I want it to, but It's still ignoring me :)



the litrature states byte 1-8 in, real terms it should be byte 0 to 7 (8bytes)
Therefore byte 3 is actually byte 2 in the CAN world and byte 1 is reserved.



[0] Message Index

[#] Next page

Go to full version