Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Controllers / Inputmode_problem
« Last post by macbahi on November 03, 2021, 02:02:58 PM »
Hi!!!

I use SC050-120 pin 32 as input.
I have option to use two sensors analog and resistance.
So I have using switch to do that as showing at the first image.
As result compilation error Initialize Hardware output must be connected to an output which is valid for initialization.

Please could you help me

thanks in advance

Cordially
macbahi
22
PLUS+1™ Service Tool / Re: File Download is greyed out
« Last post by acmall on November 03, 2021, 09:04:34 AM »
You can check if the message is being transmitted or received in the CAN Monitor. The last column labelled Dir is the message direction, R for receive & T for transmit.
23
Function Library / Re: Fault Manager issues
« Last post by SJ Industries on November 03, 2021, 04:25:34 AM »
Hi acmall, you might be right. Well I can't get it to work, everytime I use preconfigured function blocks that are locked up it bites me in the rear. Now I have to spend some ridiculous amount of time writing my own fault management system to suit the Dm1 interface on my screen.
24
PLUS+1™ Service Tool / Re: File Download is greyed out
« Last post by Andre on November 02, 2021, 08:59:30 PM »
Got it, thanks for the answer.

The issue was the connection from the termination point to the CAN LOW on the controllers connector.

I was confused with this as I saw data coming also when only the controller was connected,
but I guess that these were some kind of messages that came from the Service Tool and not the controller.
25
PLUS+1™ Service Tool / Re: File Download is greyed out
« Last post by FluidPowerTom on November 02, 2021, 05:35:37 PM »
The Service Tool will automatically connect and show 'connected' with a green light in the bottom left.  It sounds like your Service Tool is configured to use the correct gateway, so my guess is a wiring issue.  This should work with a single 120 Ohm resistor just fine.

Try switching CAN high and low inc case they're backwards.  Use a multimeter and measure ohms between CAN high and low to verify the resistor is connected.  Check for ground shorts.
26
PLUS+1™ Service Tool / File Download is greyed out
« Last post by Andre on November 02, 2021, 04:33:25 PM »
Hi,

I am new to the PLUS+1 world and trying to get the first project to work as per the getting started documents.
Download of Guide 2021.1 and Service Tool 2021.1 worked and it shows a valid Express license.

I am able to program an application and compile it without errors. Then I can close the project to P1P.
I have also an *.lhx file in the folder.

As per getting started, I shall open the *.lhx file by clicking on File -> File Download in the Service Tool. That menue is not there.
If I open the Service Tool, it shows the start page and File Download is greyed out.

If I double-click the *.lhx file in a file browser, it open the Service Tool with this failure message:

"ERROR: No ECU information available.
A connected system is required."

So I guess I have no connection to the controller. That makes sense to me as it shows "Disconnected" in the status bar on the bottom of the Service Tool.
It also shows the CG150-2 #0 (Channel 0) in the status bar and it shows a Busload.

I would assume that the connected controller should also show up from alone in the ECU List in the Service Tool, but it is empty.

The CG150 should work fine as I can read CAN Data of other connected devices with the CAN Monitor.

I tried multiple devices: 2 x MC012-110(brand new) and 1 x MC024-120(previously used) but non of them show up. On the brand new ones, the green LED is on and the used one, the green is on and the red led is blinking.

I tried to connect without termination resistors, with 120 Ohm and with 60 Ohm.


So my first and overall question is:

Should the Service Tool automatically connect to the ECU and show connected in the status bar?

27
Function Library / Re: Fault Manager issues
« Last post by acmall on November 01, 2021, 09:15:51 AM »
I haven't used the Fault Manager but I think you need the Service Tool Add-on license that adds scripting to be able to make those changes.

28
Function Library / Fault Manager issues
« Last post by SJ Industries on November 01, 2021, 07:46:56 AM »
I am having some issues with the fault manager, when loading the service tool application I am getting some normal faults with a number allocation and then I get half a dozen "undefined" faults present? I have routed 84 separate faults to the manager the documentation indicates 3300 odd faults are possible so I dont think that is the issue. I have also allocated the full 64 NVmem blocks to the manager but I dont have that many faults present (approx 10) at this stage of debugging.
Also, I have checked my subscription in serv tool and I have the professional licence but the instructions in the manual are saying to click on icons that I cant find? See below


Configure the FaultDescriptions.js file I can not find this file???
Users with a Professional service tool license can configure the FaultDescriptions.js file to ensure
customizations appear on the service tool screen.
1. Ensure you are in Design View. In the PLUS+1® Service Tool, from the View menu, select Design View.
2. Click the plus + icon next to the Resources folder to expand it.
3. Right-click on the FaultDescriptions.js file and select Delete.
4. Replace the file that you just deleted with the FaultDescriptions.js file that was created when you
used the spreadsheet to build your project
a) Right-click on the Resources folder and select Add Resource File....
b) Navigate to the location where the interface file for the service tool is stored. This location is in the
main project folder where all PLUS+1® GUIDE files are stored.
c) Find the FaultDescriptions.js file, which was created when you clicked BUILD PROJECT on the
spreadsheet.
d) Click Open to place the file in the Resources folder.
5. Load the new file into the project file for the service tool.
a) Expand the Scripts folder.
b) Expand ScriptInterface.
c) Right-click on ScriptFunction and select Reload.
The System Navigator panel grays out while the new FaultDescriptions.js file is added to the
project file.
29
Displays / Re: DM430E TEXT ISSUE
« Last post by Tor on November 01, 2021, 07:34:40 AM »
Hi Pinias,

This issue has been reported to the developers, and what I can see in the bug report it is still open.
So I'm sorry, they have not found a solution to this.

If you didn't report this issue before, please create a report in Plus+1 Helpdesk: https://danfoss.secure.force.com/dpscustomersupport/?product=software
Write a description and mention that there are an existing case with nr: P100005825.

Thanks
30
Displays / Re: DM430E TEXT ISSUE
« Last post by pinias on October 29, 2021, 06:24:26 PM »
Well, if compiled in windows 10 home edition the texts fonts are ok, they look the same on hardware as in GUIDE.

that is why I am asking if anyone is using GUIDE 2021.1 version and knows if the bug it is been fixed if working with W10 PRO

Pages: 1 2 [3] 4 5 ... 10