Author Topic: Service tool and DM1200T  (Read 1381 times)

Offline Mike AA

  • PLUS+1 Guru
  • *****
  • Posts: 108
  • Karma: +0/-0
    • Dewind Dewatering
Service tool and DM1200T
« on: August 06, 2020, 03:34:28 PM »
So I have started programming my DM1200 and went to upload the first program I wish to run. When I started the transfer with my CG-150 I let it sit for over 30 minutes and it was maybe 15% done. I disconnected and restarted with my CG-150-2 figuring maybe it would be a faster transfer speed. 10 minutes in and its maybe at 20%. Is this indeed this slow of an upload due to everything going on with the DM1200 or am I just seeing something odd going on? This is the first upload I am making for it.

Thanks,
Mike

Offline TheTurfDude

  • PLUS+1 Developer
  • ***
  • Posts: 37
  • Karma: +0/-0
    • Trebro Turf Equipment
Re: Service tool and DM1200T
« Reply #1 on: August 06, 2020, 04:10:04 PM »
When I was playing around with the DM1000 I saw the same. If you look at the size of the LHX file compiled for a DM1000/DM1200 you will notice they are significantly larger than an LHX compiled for a DP6xx or DP7xx. I found that if you wait long enough the CG-150 will do the job, but I highly recommend ditching the CG-150 and using the USB interlink gateway. Downloads to the DM1x00 display using the interlink gateway take about 8-20 seconds.

Offline pinias

  • PLUS+1 Guru
  • *****
  • Posts: 197
  • Karma: +4/-0
Re: Service tool and DM1200T
« Reply #2 on: August 06, 2020, 04:35:48 PM »
Hey Guys,

ok, the 1st time you flash the DM display takes around 3 to 4 hours if you use the CG150, I think it configures everything.

next time you flash it, it will be around a minute with the CG150.

by the way, make sure you are using the latest HWD version, the previous version had an issue with the NV memory, basically it did not retain the value after cycling power.

as far as I know from the PLus1 help, the latest HWD version fix that


Offline Mike AA

  • PLUS+1 Guru
  • *****
  • Posts: 108
  • Karma: +0/-0
    • Dewind Dewatering
Re: Service tool and DM1200T
« Reply #3 on: August 06, 2020, 05:40:54 PM »
The long time is indeed only the first upload. I just changed the layout and reloaded in 30 seconds. Its missing a bunch of graphics and more stuff but way better than the over 2 hours for the first upload.

How do I use the USB interface? I had two from wanting to try on the DP720 but never got it to work right. I'm guessing I am missing drivers.

Mike

Offline Stefan

  • Administrator
  • PLUS+1 Expert
  • *
  • Posts: 70
  • Karma: +0/-0
Re: Service tool and DM1200T
« Reply #4 on: August 07, 2020, 11:37:33 AM »
Hi,

You need a special cable for DM1000 and DM1200. You can order it from your Danfoss distributor and the part number is 11231512.

Best regards
Stefan, PLUS+1 Helpdesk

Offline Mike AA

  • PLUS+1 Guru
  • *****
  • Posts: 108
  • Karma: +0/-0
    • Dewind Dewatering
Re: Service tool and DM1200T
« Reply #5 on: August 07, 2020, 02:07:42 PM »
Stefan,

Thanks for that, I figured that out after double checking the cable I had from my WS103 wasn't the correct one. I got bluetooth to work and wifi and the CG-150-2, which loads in a minute or two.

Offline G30RG3

  • PLUS+1 Developer
  • ***
  • Posts: 47
  • Karma: +1/-0
Re: Service tool and DM1200T
« Reply #6 on: August 07, 2020, 04:27:14 PM »
Hi,

Just a suggestion, maybe worth trying...
What happens if you load an "empty" file, and set the baudrate to 1Mbit, reboot, and load the real application at the higher baudrate?
You'll need to make sure there are no other devices on the same bus, but that should give you a 4 times faster load, so unplugging for a quicker flash...
You'll need to reboot the screen again to get back at the standard baudrate.

Offline dlewis

  • PLUS+1 Expert
  • ****
  • Posts: 83
  • Karma: +2/-0
    • Getman Corporation
Re: Service tool and DM1200T
« Reply #7 on: December 22, 2020, 03:13:31 PM »
I purchased the USB cable 11231512 connected it to my laptop and my DM1000 but I can't connect the service tool utilizing this cable.  I see in the service tool that it has Display as one of the Gateway options, but there are no Channels for it and therefore I can't choose it.  Is there some special driver that I need other than the standard drivers downloaded with Update Center?

Offline dlewis

  • PLUS+1 Expert
  • ****
  • Posts: 83
  • Karma: +2/-0
    • Getman Corporation
Re: Service tool and DM1200T
« Reply #8 on: December 22, 2020, 03:54:13 PM »
Never mind. Watched the YouTube video https://www.youtube.com/watch?v=X3mR-7OH-Ho and changed my setting accordingly.

Offline turboshad

  • PLUS+1 Developer
  • ***
  • Posts: 14
  • Karma: +3/-0
Re: Service tool and DM1200T
« Reply #9 on: February 10, 2021, 07:54:47 PM »
Anyone programming the DM screens that doesn't have this cable needs to buy it. It dropped my download times from 30 minutes to 45 seconds. It was paid for the in the first two downloads. Thank you for the part number dlewis!