PLUS+1 Software > Function Library

TSC1 Lost Messages

<< < (2/3) > >>

So I have done a number of things since the last time I posted.  I've tried different loop times: 1ms, 2ms, 5ms, 10ms.  The fault still occurs no matter what the loop time is.  I updated the .hwd file withing the .p1p to the most up-to-date version for both the controller and the display.  I even completely replaced the controller thinking it might be a CANBus transceiver problem with the original unit.  All of these items had no effect.  The weird thing is, whether it was with the original controller or the new controller, the problem doesn't occur until the machine has run for at least 20-30 minutes.  Then it does it very consistently after that, like every minute or 2.  Each time it does it, you have to turn the machine off and back on again.  Fortunately, this is just on a prototype machine and not on hundreds of production machines.  If it were, I'd be in a big mess.  I'm about ready to scrap the idea of a TSC1 controlled throttle and change to an analog throttle.

Hmmm, bizarre!

Is the bus only connected to your controller or are there other things connected to it? Is something else happening after this time period?

Are you using a monitor to send the messages or an MC controller?  Monitors loop times can be all over the place.  Have you taken a log of the messages with CANKing while the error occurs, does the load increase at the time of the fault?

Do you have 120 ohm resistors at each end of the bus?

Tried a shielded CAN cable?  Using gold plated pins in connectors?

Sorry for asking the obvious questions, which no doubt you have probably gone through already.  This really intrigues me  ;)


There are other devices on the bus, but as far as I can tell there is nothing else happening to trigger the event.  I am using an MC050-112 controller to send the messages, not a display.  I have monitored the bus with CANKing when an event occurs.  Before it happens, the buss load is a consistent 21-22%.  After it happens the buss load goes all over the place, very high to very low, but I attribute this to the TSC1 message missing for 1000ms and then going to a transmission rate of 0.6ms.  As far as I can tell, there is no other rogue message, or slug of messages, that is occuring to trigger the event.

No problem asking the obvious questions, I'd do the same.  120 ohm resistors are in place at each end of the buss.  We are using shielded CAN cable and all CAN connections use gold plated pins and sockets.


what engine are you trying to work with?

the CAT engines tells you how often the PGN 0 should be sendtin order to keep it running at a steady RPM.

now, what priority have you set?

the engine manufacturer should tell you how the priorities has been set.

otherwise I would say you may have a short circuit from other circuit but it is seen by the can bus through the shield if you have it connected to chassy GND, or it may be a loose connection.

I would check that everything else is working as I excpect so that I can isolate the CAN issue.

I hope this helps.

Did this issue ever get resolved as I have a similar situation on several machines we have produced over the past couple of years?


[0] Message Index

[#] Next page

[*] Previous page

Go to full version