Author Topic: IOX024-120 Red LED Solid Green LED Flashing  (Read 764 times)

Offline dloww17

  • PLUS+1 User
  • **
  • Posts: 8
  • Karma: +0/-0
IOX024-120 Red LED Solid Green LED Flashing
« on: March 16, 2021, 01:18:27 PM »
Hi everyone,

I have an IOX module connected to the Service Tool. I was able to connect to the Tool fine and scan the system, but the red LED is solid and the green LED is flashing.

I can't remember what that meant - I think when the red flashes it means it's in boot loader mode. I doubt this is the case.

Thanks in advance.

Offline FluidPowerTom

  • PLUS+1 Guru
  • *****
  • Posts: 265
  • Karma: +20/-0
Re: IOX024-120 Red LED Solid Green LED Flashing
« Reply #1 on: March 16, 2021, 04:17:28 PM »
Expansion modules have different causes for the LEDs flashing than the microcontrollers.  Red LED blinks when a message is sent, and green LED blinks when a message is received.  So, basically red blinking as well as green blinking is OK.  If red is on solid that means the CAN bus is off.  The green will blink at exactly 1 Hz if no messages are received.
Mechanical Engineer
Hydra-Power Systems - Distributor - Pacific Northwest

Offline dloww17

  • PLUS+1 User
  • **
  • Posts: 8
  • Karma: +0/-0
Re: IOX024-120 Red LED Solid Green LED Flashing
« Reply #2 on: March 16, 2021, 06:03:41 PM »
Thanks, FluidPowerTom.

I grabbed a new IOX module and the red LED is ON and not blinking. I am guessing it is because I just have the IOX module plugged into a test bench by itself.