PLUS+1™ Tools > PLUS+1™ GUIDE

Guide 12.2 User Interface Lag

(1/3) > >>

acmall:
Is anyone noticing UI lag with Guide 12.2 as the program size increases.

I have been testing 12.2 and on my system there is a considerable UI lag as the program size increases. It happens at the end of a command for instance when adding components then pressing ESC to end or after clicking Ok to confirm deleting a component.

It also happens when routing a signal. Clicking to connect the second endpoint of the signal results in the lag. If trying to route signals for several components there are a few different outcomes. Either the first click for the next signal is missed, the signal appears after the lag but is not connected to the component, or the signal is connected to the wrong component.

Appears to be related to program size as there is initially no UI lag with a new program, the UI lag gradually increases as the program size increases. I can artificially reproduce the UI lag by creating a page and adding about a number of switch 16 components then creating multiple copies of the page, no need to connect signals. The more copies of the page that are added the longer the UI lag becomes.

Be interested if anyone else is seeing the same behavour.

Fredrick:
I also have the same behavior and it feels like the UI lag increases each time a new GUIDE version releases.
Two important things I learned when working in GUIDE

1. Always open a project file (.p1x) on the local drive and not on any network or cload drive.
2. Ask your IT department (if any) if they can exclude the GUIDE program files from the realtime antivirus scanner, also exclude a folder on your computer where you work with your GUIDE projects.

Disable "Undo/Redo" under the menu "Options/General settings" also makes GUIDE a little bit faster but it´s not an option for me.

The above only help´s a bit, the UI lag is still a big problem on larger programs.

acmall:
Thanks @Fredrick for confirming.

For me the UI lag in previous versions is minor but in 12.2 it is unworkable. All files are local and virus scanner excludes Guide files. I just tried disabling Undo but this made no difference.

Ironically the performance of the PLC editor has improved dramatically, opens almost instantly and switching tabs is instant. Previously, for me at least, there was a 1.5 second delay when switching between open tabs.

Tor:
Hi,

I can confirm that there is an issue with the 12.2 release that make it slow, especially with large projects. This has been reported to the developers and it has the highest priority.
I've been told that the root cause is found, and a patch will be released as soon as it's fixed and validated. 

I'm sorry if this has caused any problems for you.


Have a nice day.

acmall:
Hi @Thor

Thanks for the update.

While you are taking UI, do you know why I am not able to drag the toolbar that is now at the side by default back to the top? I would like to put it back into the empty space that it left behind in the top toolstrip rather then have it take up additional space from the CAD area.

Navigation

[0] Message Index

[#] Next page

Go to full version