PLUS+1™ Hardware > Controllers

Multifunction Input for reading pressure sensors


Hi Guys,

I have a pressure sensor which supplies me with a 4 - 20mA Output. To connect it to the MC088 I used a resistor in order to give me a signal of around 870mV to 4200mV. My only issue now is I can't get the controller to read the input. I get the measured result with my multimeter, but when connecting to the controller there is nothing on the input pin.

It should be mentioned that the system is powered from 24Vdc, and the sensor range would be from 0-600bar.

I have tried different pin configurations out of pure frustration but still nothing. The pin I am using is C1-P26, which is Multi function input. I have also tried changing it up between the low side and high side shunt. Am I missing something simple on the pin configuration side of things?

Any advice?

Thanks in advance.

Hey Louis,

Don't know if you've already looked but the Danfoss input configuration manual (520L0931) shows a 4-20mA sensor input with a resistor. Be sure to hook the ground side of the resistor to sensor ground on the controller. Other than that, maybe try changing the input range in the program?

Hope this helps!

Are you monitoring C1p26.voltage on the Service Tool and still seeing nothing?  Maybe there's a wiring issue to the controller?  This should work, as I've done it myself.

Hi Guys,

Thanks for the feedback. Currently the wiring is on my desk as I'm busy testing all the systems, so there's not a lot of room for wiring issues as its a short piece of wire connecting the sensor to the controller, both which are running from the same ground. What I have seen though, is that when I monitor the voltage on the service tool and I connect the wire, the value jumps up to about 24 and then back down to zero, and this happens over and over as long as this wire is connected. I managed to find the document 520L0931, and noticed that they refer to "sensor ground" and not the controller ground. I'm not sure whether this would make a difference?

My wiring is as per the attached.

Hi Guys,

I managed to resolve the issue, so wanted to post for future users. It seems it was a rookie mistake on my side. I'm using a Meanwell Power Supply to act as a protection device between the controller input and alternator supply as we've had some alternator failures cause massive overcurrent conditions and destroy systems. The supply to the sensor was taken from the power supply input and not the output to the controller, as well as the neutral signal, meaning that there was no connection between the common signal between the controller and the sensor.

It took some blind staring at the setup in order to realize this, but once I did, I changed the supply and everything works great. The system is working perfectly now.

Thanks for the help!


[0] Message Index

Go to full version