PLUS+1 User Forum

PLUS+1™ Hardware => Displays => Topic started by: Guciu on October 07, 2020, 01:34:46 PM

Title: DM1000 Widget library basics
Post by: Guciu on October 07, 2020, 01:34:46 PM
Hello everyone!
This is my first post here, so please don't be too hard on me. :)
I've recently bought a DM1000 display in  company that I work for. We want to use it as an instrument cluster for a machine using CAN j1939. I am trying to make it work :) I have read or seen tutorials on youtube and learned how to use some of functionalities of this fine display. So far I was able to display PDF files and static images that change when pressing a button. I have downloaded j1939 library and widget library. I've managed to connect CAN output from ET1_RX1 block to custom indicator in my SHOW screen, however I have a problemn with a widget library. When I create a Show screen block, do not put any inputs to it, make it appear on screen and all that , and then follow the tutorial on widgets, when I try to compile I get :
Code: [Select]
*** ERROR 446 *** [PLUS1_IDE] PLC Code Compilation Failure {Convert PLCopenXML -> CCP}Why is this happening?
Regards.
Title: Re: DM1000 Widget library basics
Post by: spittet on October 07, 2020, 06:54:49 PM
Which version of GUIDE are you using?
Title: Re: DM1000 Widget library basics
Post by: Guciu on October 07, 2020, 08:09:50 PM
The newest one, 12.1.7 . All libraries downloaded via update center.
Title: Re: DM1000 Widget library basics
Post by: dainbramage on October 30, 2020, 08:54:55 PM
Don't know if you solved this problem yet. Did you add the Guide PLC extensions to a new PLC unit? There are some preliminary steps for using the widgets in the manual and skipping any of those can produce that error. I have had to delete those additions and put them in again to get the file to compile also.
Title: Re: DM1000 Widget library basics
Post by: leshem on March 23, 2021, 12:46:41 PM
I have been in the PLC for 15 years, but had never had such a hard learning curve.
I had downloaded SW into the MC038, but failed to program any of the displays, stuck with the widgets down load.
I tried the followings:
https://www.youtube.com/watch?v=plAIvsKNlwg
https://www.youtube.com/watch?v=hWFVZm5DQXQ
https://www.youtube.com/watch?v=FLmse2GPSVM
https://www.youtube.com/watch?v=6E_9Hv-2Acc