PLUS+1 Software > General controls

How to view error logs


I had a problem with GUIDE and had to reinstall it. But now when a project compiles and returns errors, the error tab is blank. Nothing. Is there a way to 'enable' this tab?

I had a similar problem yesterday.  When I compiled a project it returned an error, but no error was shown in the error screen.  I then recompiled the program without making any changes and it compiled fine.

I think it was just one of those days ....
Now that everything had turned out fine and I have few minutes to spare I can tell you the whole story.
It all began with a system crash. I was working on a project when I had a system halt and I had to restart my computer. But since I had it all saved and compiled I didn't pay much attention to rebooting and checking again. I just packed my laptop to my backpack and went 300 km to a company at which vehicle I'm working on currently. I arrived at something close to 5pm, when everyone was just about to leave (or had already left), turned on my laptop, ran the project and BAM! GUIDE retuned an error and from that point on, the project only opened in 48%. Prjopen.exe process was running like crazy using from 200 to 500 MB of RAM just to dump it and start again. Needless to say I felt stunned and crippled. I didn't know what to do. To top it all, all the GUIDE settings were.... gone. To be frank, I first thought it was a problem with the environment. I had no history, I couldn't 'undo' anything. Mouse wheel for zooming was not working and I couldn't change page names with 'q'. I've tried reinstalling, downloaded the GUIDE setup from the web again and reinstalled again. I mentioned earlier I had a project compiled. Well.... I didn't want to download to the controller. I got errors. Then I started getting errors in GUIDE saying that it can't find specific files when I tried compiling other old projects. After that I tried reinstalling again and the setup said that it can't install in "C:\Program Files\SD\....\5.0” because  '.' (dot) is somehow not supported by the setup program. To tell you the truth, that was the thing that had topped it all. I packed my bags and went to my hotel room. Drive to the hotel let me clear my head and after I got there I started searching. Turns out all those things that were missing are in the options menu. Stupid, I know. But I never really had to turn them off or on so I never bothered to look in the first place. I deleted all instances of GUIDE on my laptop and started installing from scratch. It turned out I CAN install in a ''C:\...\5.0\" directory and from there on it went downhill. As to the old corrupted project, it still halted at 48% but when I've closed prjopen.exe several times (I've tried opening it multiple times) it ..... opened. Don't know how or why but it did. The only problem I had was with the error logs. They were missing. No matter how many times I tried compiling, they were blank. Compiler messages and build messages were present, but errors were blank. The project returned errors when compiling.  So I took an old project as a template and started adding pages to in from the now-not-so-corrupt project. After a few tries I found the culprit. The page which I had made last when everything was still ok was in pieces. The blocks used were present and they were in the general location where I had put them (some were more to the left or right but still nearly there) but the wiring was ..... to say nonexistent would be a lie. The wires were present. Only the connections were a mystery. Some blocks were connected, others weren't. Some connections led to blank spaces, or to blocks which were never meant to be connected. All the outputs were let loose. I've spent somewhat an hour or so on that single page alone, trying to retrace everything. But I was happy. For the first time in 6 hours I was happy. I went to sleep after midnight but the next day, when (almost) everything that was supposed to run, ran... that made up for all the stress and anger.
So that's my story. I hope such things won't happen to any of you, as it is an experience I personally can do without.

The error logs weren't present in the not-so-corrupted-now project but they are visible in new ones so I'm blaming the seems-like-it-may-indeed-be-corruped project for that.



[0] Message Index

Go to full version