Author Topic: DP600 flashes red LED, does not communicate on CAN bus.  (Read 10868 times)

ET

  • Guest
DP600 flashes red LED, does not communicate on CAN bus.
« on: August 09, 2012, 10:19:39 PM »
I've got two DP600 displays, which are in an unknown fault state.
They were working fine last week; I was programming them for a paving machine.
When powered on, they blink the red LED on the lower right at approximately 150 blinks/minute (2.5 Hz), and do not communicate on the CAN bus.

1. What does this mean?
2. How do I fix it?

ET

  • Guest
Re: DP600 flashes red LED, does not communicate on CAN bus.
« Reply #1 on: August 10, 2012, 10:49:59 PM »
Further info, plus resolution, for future readers and posterity:

The CAN bus wire came loose during a program upload, and after this, the red LED was flashing at 2.5 Hz, with a blank screen on the DP600 displays.
If this happens, the screens will only talk on the same CAN pins as the ones they were using when the upload was in progress, and will appear in the service tool as something like "bootloader_mode".
So, if they were interrupted during an upload using pins 3, 4, and 5, you need to hook them up on your test bench with pins 3, 4, and 5; If they were using 5, 6, 7, use pins 5, 6, 7.
Once the service tool detects them in bootloader mode, just upload a DP600 program to them, ignoring/overriding appropriate warnings that come up about memory, etc.
After this, they will work normally.

Quax76

  • Guest
Re: DP600 flashes red LED, does not communicate on CAN bus.
« Reply #2 on: August 13, 2012, 08:06:37 AM »
You could also reprogram the display with its own CAN Gateway on the Binder connector C3

ET

  • Guest
Re: DP600 flashes red LED, does not communicate on CAN bus.
« Reply #3 on: August 13, 2012, 05:44:08 PM »
According to the tech info PDF, C3 is a USB connector, not a CAN connector.
Is that not correct?

Quax76

  • Guest
Re: DP600 flashes red LED, does not communicate on CAN bus.
« Reply #4 on: August 14, 2012, 08:03:58 AM »
It's not a CAN connector, to connect other CAN nodes to the net.
When you connect the USB pins to the Service Tool, the Display works as a CAN gateway.
There is no CG150 or Kvaser needed, if you have a DP6xx in the system.

SalvadorMoore

  • Guest
Re: DP600 flashes red LED, does not communicate on CAN bus.
« Reply #5 on: August 05, 2013, 04:15:13 PM »
I've got two DP600 displays, which are in an unknown fault state.
They were working fine last week; I was programming them for a paving machine.
When powered on, they blink the red led light on the lower right at approximately 150 blinks/minute (2.5 Hz), and do not communicate on the CAN bus.

1. What does this mean?
2. How do I fix it?
hello were you able to sort out the problem? I am facing similar issue with my led lights..The lights are not properly communicating with CAN bus... Can you help me with some sort of solution..Waiting for reply thanks in advance:)
« Last Edit: August 06, 2013, 05:53:40 PM by SalvadorMoore »

Offline Federico

  • PLUS+1 Developer
  • ***
  • Posts: 18
  • Karma: +1/-0
    • Centro Hidráulico S. A.
Re: DP600 flashes red LED, does not communicate on CAN bus.
« Reply #6 on: August 16, 2013, 04:29:44 PM »
Hola, Tengo un DP610 con el mismo problema.
Han encontrado la solución?
Probé conectarlo con todos los can y nada¿?
Saludos

****************

Hi, I have a DP610 with the same problem.
They found the solution?
I tried connecting it to all CAN and nothing?
Regards