Recent Posts

Pages: 1 ... 8 9 [10]
91
PLUS+1 CS Hardware / Re: Connect Portal API
« Last post by Tor on December 06, 2023, 07:01:38 AM »
Hello Beezkneez,

This is nothing that I have any information about.
Please contact PLUS+1 Helpdesk and ask: https://www.danfoss.com/en/products/dps/software/software-and-tools/plus1-software/#tab-support
Select "Plus+1 Connect" in the product drop down list.

Have a nice day.
92
PLUS+1 CS Hardware / Connect Portal API
« Last post by Beezkneez on December 05, 2023, 10:47:39 PM »
Has anyone heard of a release date for the PLUS+1 connect portal API? We used the Proemion API for some of our own apps when we ran the WS units. I have still not heard any info on when we can expect something similar for the PLUS+1 telematics product line.
93
I/O Modules / OX24 or IX24 C1p02_Pwr updated problem
« Last post by macbahi on December 05, 2023, 10:45:39 PM »
Hello,

I use Ox024 and IX024.

When I use them with AddrMode=1    C1P02_Pwr  updated  is true.

But when I use AddrMode=2  the C1P02_Pwr Updated   stay usually false.

Both cases C1P02 volt equal 12V.

Please where is the problem of C1P02_Pwr updated with mode AddrMode=2?

Thanks in advance for you help

With best regards
mac bahi
94
I/O Modules / Re: I/O module can message identifier Addrmode 2 procedure
« Last post by macbahi on December 05, 2023, 09:41:45 PM »
Hello,

All device have same baudrate 250K. 

Yes I too have only use AddrMode=1.   And usually C1p02_pwr   update it's Ok.

But when I switch with AddrMode=2   the C1p02_pwr update is false.  I lose my communication with Ox024 and IX024.

I think is that the problem.

I don't know why C1p02_pwr  update is false in this cas, despite C1p02 volt = 12 V.

I hop have some answer from expert danfoss users.

Thank in advance for your help

With best regards

Mac bahi

95
PLUS+1 GUIDE / Re: Input hexadecimal???
« Last post by G30RG3 on December 05, 2023, 11:15:11 AM »
Cheers acmall, i didn't know it was there :)

I tested it a bit, and it seems i need to make some logic if the first decimal after the point (right side) is "0", then it gets lost in this function and the first decimal >0 is displayed...

As far as I can see, it just shows the 9 decimal digits right from the decimal point at Right,
You need to add the leading 0's to this number to see the real number as we're used to work with
It's similar to what Jashom1 did but the multiplier is 0x501502F9

At Left it shows the decimal digits at the left of the decimal point.
96
I/O Modules / Re: I/O module can message identifier Addrmode 2 procedure
« Last post by Lukey on December 05, 2023, 06:45:24 AM »
Sorry I don't know the cause of your error frames.

You mention you are using hardware Ox024, IX012, sc024, DM430 and Keypad.

Is it possible you may having conflicting identifiers? or is 1 of hardware devices on a difference Baudrate?

I have seen this before personally, a device with a different Baudrate will show as error when monitoring with CAN monitor.

I personally have only ever use AddrMode = 1, therefore I set a fixed Node/N1 in my Guide controller program and with Service Tool for the I/O module, this works flawlessly for me.
97
I/O Modules / Re: I/O module can message identifier Addrmode 2 procedure
« Last post by macbahi on December 04, 2023, 05:04:43 PM »
Hello Lukey,

Thank you very much for your replay.
I had using this table I/O Module CAN Message Identifiers.  Please see image.

Befoe I use Id 56 (7)    but now AddrMode=2  is 0x1B8 and 0x338
                     64 (8)    but now AddrMode=2  is 0x1C0 and 0x340

I didn't find an I/O Module CAN Message Identifiers example but I think my addressage is correct.  But I didn't know step by step to do that.
What I did: I change my configuration in Plus+1 as I tell you and after that I change by service tools AddrMode to 2 and Frame to 1.

As you see in my second image I don't know about Frames error.  And it's updated every time.  As you see is 16 but it can be higher than that.

Please Could you tell me the cause of those frame errors.

Thanks for help
with best regards
mac bahi
 
98
PLUS+1 GUIDE / Re: Input hexadecimal???
« Last post by acmall on December 04, 2023, 09:07:08 AM »
Hi sverreo, I can't help with the details as I have not used it. I just remembered seeing it in the library.
99
I/O Modules / Re: I/O module can message identifier Addrmode 2 procedure
« Last post by Lukey on December 04, 2023, 06:41:19 AM »
I think your addressing is not correct, see attached extract from Expansion Module manual/s.
You need to program your controller TX ID and that corresponds to the Expansion module RX ID that you need to set with the Service Tool File.


100
I/O Modules / I/O module can message identifier Addrmode 2 procedure
« Last post by macbahi on December 04, 2023, 04:51:53 AM »
Hello,

It's my first time using can message identifier AddrMode 2 to configurate adresse to Ox024  and IX012 as shown in my first image.
I use also sc024, DM430 and Keypad

First in service tools I see  0,56 and 0,64.  It's like using AddrMode = 1.

In my second picture , I see many error Frames in CANKING.

Please could you tell me what is the cause of those error frames?
What is procedure to do this configuration?

Thank you very much for your help

mac bahi
Pages: 1 ... 8 9 [10]