Recent Posts

Pages: 1 [2] 3 4 ... 10
11
Displays / DM1000
« Last post by a.damato on February 16, 2024, 09:24:05 AM »
Hello Everybody,

I would like to ask some question regarding the block "Read Array from Application log".
When i try to read the "LineCount" Output. I get a weird amount of line.

I am using a DM1000, menu buttons , no Touch.

In the help manual i read X6 : Total number of lines in the application data log.
So i should get from this output 1,2... depending on the amount of line in the applog file.

Right now i am using a trick that register the number when i switch on the Display.
Because it's reading right when i switch on the device but in the moment i write a new line this number has a weird behaviour.

I am wondering if anyone had this issue?

Thanks.
12
Code sharing / Read Array from Application Log & Write Array to File
« Last post by Lukey on February 15, 2024, 04:37:56 PM »
I have tried to use the Read_Applog and Write_USB blocks although these are limited to a length of ARRAY[125]U8 (125 Characters) for each line of the Applog, anything greater and the Applog line is truncated on conversion.

My Applog line are longer than 125 characters and I would like to rename the Applog csv file to a custom STRING/TL that the operator inputs from the Display (DM1200T), I have attempted to use the 'manual' blocks Read Array from Application Log & Write Array to File but have been unsuccessfully.

The blocks will accept greater than 125 characters but I cannot get the Write Array to File block to write more than 1, sometimes 2 lines of the Applog.

I seem to be missing the connection that tells the Write Array to File block to start another line in the csv file.

Does anyone have a working example of the Read Array from Application Log & Write Array to File that is writing more than 1 Applog line to csv.
13
Controllers / Re: AnIn used as 24vdc DigIn
« Last post by Lukey on February 15, 2024, 02:18:18 PM »
Thank you acmall.

Yes odd that the heading is CAN

There is mention Middle range and High range, nothing about Low range.

I have only seen the range selection on the multifunction inputs, so I'm not sure about this information.

Overall it does mention max of 36v  ???

I'm not convinced.
14
Controllers / Re: AnIn used as 24vdc DigIn
« Last post by acmall on February 15, 2024, 10:32:28 AM »
This is the document for the MC0xx-1xx family
https://assets.danfoss.com/documents/206067/BC152986484529en-000701.pdf

For some reason the input and output specifications are in a section with the heading CAN.
15
Controllers / Re: AnIn used as 24vdc DigIn
« Last post by Lukey on February 15, 2024, 10:11:40 AM »
11130915 / MC012-110, pin 5
16
Controllers / Re: AnIn used as 24vdc DigIn
« Last post by acmall on February 15, 2024, 09:19:02 AM »
Which controller are you using? Which input pin?

It would be worth checking the ratings for the input you are using as there is a good possibility it will be rated to more the 24V. This can be found in the Controller Family Technical Information document for the controller family you are using.
17
Controllers / AnIn used as 24vdc DigIn
« Last post by Lukey on February 15, 2024, 02:52:39 AM »
I'm trying to use the smallest size possible controller, therefor id like to use a 5v AnIn pin as a DigIn with 24vdc input. from the switch

Is it as simple as using a resistor to drop the 24vdc down to 5vdc?

Anyone done this before and can advise what size resistor they use?

*EDIT FYI, I do not want to use the 5+ from the controller or use a relay to switch the 5+.
The application requires it to be compact and simple.
18
PLUS+1 GUIDE / Re: Missing fonts error when trying to compile with 2024.1
« Last post by Tor on February 14, 2024, 08:28:50 AM »
Hello williamk,

Sorry, I didn't mean that you should know what I have commented in another thread.  The comment "..the same thing in another thread...." was just to inform that more people had the same issue.   :D


Have a nice day.
19
PLUS+1 GUIDE / Re: Missing fonts error when trying to compile with 2024.1
« Last post by williamk on February 13, 2024, 05:28:52 PM »
Ah, I looked quickly before posting and didn't see that post.  Thanks for the reply.
20
PLUS+1 GUIDE / Re: Missing fonts error when trying to compile with 2024.1
« Last post by Tor on February 13, 2024, 09:05:58 AM »
Hello williamk

I will post the same thing as I posted in another thread with the same issue:

"Yes, there seems to be a bug when it comes to some fonts and this is reported. I hope they can find a a solution quickly, and I guess, get a patch out.

Sorry about the inconvenience."



Have a nice day.
Pages: 1 [2] 3 4 ... 10