Author Topic: MC024-021 incorrect tool key  (Read 7851 times)

power4

  • Guest
MC024-021 incorrect tool key
« on: June 12, 2013, 04:56:18 PM »
I just started to test a new MC024-021 controller, and the service tool shows a error message saying incorrect tool key. Then, when I tries to download a successfully-compiled firmware into this controller, the service tool shows "The selected file uses a different OS (10106599v210) than the current application (10106599v230). Even I select OK to proceed to download the application, it won't work.

Does anyone have the similar experience as mine?

Thanks!






Offline Neil

  • PLUS+1 Expert
  • ****
  • Posts: 93
  • Karma: +2/-0
Re: MC024-021 incorrect tool key
« Reply #1 on: June 12, 2013, 09:21:54 PM »
Hi there.

did you build the P1P file?
There is a function in there where you can add toolkey to the application.
You need to add this tool key to the service tool, in this case the toolkey is called HELLO.

In the service tool navigate to options/toolhet then type HELLO in this instance.

power4

  • Guest
Re: MC024-021 incorrect tool key
« Reply #2 on: June 17, 2013, 04:21:04 PM »
Thanks Neil. Finally, Helpdesk solved my issue. I put "uncertainty" in the window to ask for a ID.

Offline CShultz

  • PLUS+1 Developer
  • ***
  • Posts: 25
  • Karma: +0/-0
    • TST Hydraulics
Re: MC024-021 incorrect tool key
« Reply #3 on: December 17, 2013, 03:01:16 PM »
I had similar problems when hooking up to the MC024-021 Automotive control.  So I went into GUIDE and created a toolkey.  However once I loaded this to the service tool and entered my toolkey it erased all the factory set Automotive control configurations.
Is there anyway to reverse what I did?

Offline CShultz

  • PLUS+1 Developer
  • ***
  • Posts: 25
  • Karma: +0/-0
    • TST Hydraulics
Re: MC024-021 incorrect tool key
« Reply #4 on: December 20, 2013, 06:23:58 PM »
PS - Solved my problem.  I had to request the P1D file from Danfoss.
Thanks!