PLUS+1 Tools > PLUS+1 Service Tool

File Download is greyed out



I am new to the PLUS+1 world and trying to get the first project to work as per the getting started documents.
Download of Guide 2021.1 and Service Tool 2021.1 worked and it shows a valid Express license.

I am able to program an application and compile it without errors. Then I can close the project to P1P.
I have also an *.lhx file in the folder.

As per getting started, I shall open the *.lhx file by clicking on File -> File Download in the Service Tool. That menue is not there.
If I open the Service Tool, it shows the start page and File Download is greyed out.

If I double-click the *.lhx file in a file browser, it open the Service Tool with this failure message:

"ERROR: No ECU information available.
A connected system is required."

So I guess I have no connection to the controller. That makes sense to me as it shows "Disconnected" in the status bar on the bottom of the Service Tool.
It also shows the CG150-2 #0 (Channel 0) in the status bar and it shows a Busload.

I would assume that the connected controller should also show up from alone in the ECU List in the Service Tool, but it is empty.

The CG150 should work fine as I can read CAN Data of other connected devices with the CAN Monitor.

I tried multiple devices: 2 x MC012-110(brand new) and 1 x MC024-120(previously used) but non of them show up. On the brand new ones, the green LED is on and the used one, the green is on and the red led is blinking.

I tried to connect without termination resistors, with 120 Ohm and with 60 Ohm.

So my first and overall question is:

Should the Service Tool automatically connect to the ECU and show connected in the status bar?

The Service Tool will automatically connect and show 'connected' with a green light in the bottom left.  It sounds like your Service Tool is configured to use the correct gateway, so my guess is a wiring issue.  This should work with a single 120 Ohm resistor just fine.

Try switching CAN high and low inc case they're backwards.  Use a multimeter and measure ohms between CAN high and low to verify the resistor is connected.  Check for ground shorts.

Got it, thanks for the answer.

The issue was the connection from the termination point to the CAN LOW on the controllers connector.

I was confused with this as I saw data coming also when only the controller was connected,
but I guess that these were some kind of messages that came from the Service Tool and not the controller.

You can check if the message is being transmitted or received in the CAN Monitor. The last column labelled Dir is the message direction, R for receive & T for transmit.


[0] Message Index

Go to full version