PLUS+1 Hardware > I/O Modules

Issue in enabling hardware pin at connector 1

(1/5) > >>


I am working on a project that uses Danfoss Plus+1 software tool and SC050-120 hardware.

The issue we have been facing in enabling the hardware pin 34 and 46 connected with Connector 1. For C1P46 we can see in software that output pin state changes from low to high but same does not appears to be at controller hardware end. Same behaviour appears when we examine C1P34. We draw the same connection diagram for C1P34  but we observed no state change in software as well hardware.  We are referring SC050_120 Hardware description Application interface document  for the reference

Could anyone please suggest how to connect the external load or is there any other initialization required to be done in software?

Thanks in advance

A couple of basics to check: -

* Have you connected power to pins 47, 48, 49 & 50?. These pins are the power supplies for the outputs.

* Have you loaded a program into the secondary controller? Someone else may be able to confirm but I think there needs to be a program loaded in the secondary for the outputs to operate. A blank program complied from the secondary template should be enough to get started.

Thanks for the ack Acmall

Well, as you said I tried both things..

1. I can see that pins 47, 48, 49 and 50 are up and working as expected

2. For flashing the secondary controller, I choose "secondary version" under drop down of "Hardware" section while creating new project. Without any software change, I tried to flash the secondary controller but error pops out " No valid target ECU found". Attaching the screenshot as well of that particular error.

P.S. I have ben trying to attach the image I dont know why but when I attach it, I can not save message.

So I am flashing with the help of Service tool and I can see no ECU option is available under "Download File to ECU option" and status is "No valid target ECU is found "

Please let me know if more info required and guide us what else can I try to resolve it..

Hi ShaswatD,

Do you see the secondary controller in the Service Tool?
You can right click on the ECU List and "Copy ECU List to clipboard" and paste it here.

Are you connected to CAN0 (C1P03 & C1P04) or CAN1 (C1P20 & C1P21)? The secondary controller is only accessible when connected to CAN0.

In the service tool ECU list the first number is the Net (CAN0 or CAN1) and the second number is the node. As delivered the SC050-120 nodes are 27 for the primary and 28 for the secondary. If you haven't changed the node numbers in your program you should see: -

* When connected to CAN0

* When connected to CAN1
To attach an image click on Additional Options below the message entry box and choose the image file under Attach:.


[0] Message Index

[#] Next page

Go to full version