Recent Posts

Pages: [1] 2 3 ... 10
1
Controllers / Re: RX message can problem
« Last post by acmall on Today at 09:20:58 AM »
The controller can't send and receive simultaneously on the same CAN bus.

If you don't have another controller to test with you could connect CAN_0 & CAN_1 together so that you can send on one and receive on the other.
2
Controllers / RX message can problem
« Last post by topal on January 16, 2022, 04:47:51 PM »
Hello,

I'm back with a new problem, which is the following

I want to test the reception of a can message to light a bulb when C1P06 is at 12 Volt

with CAN Monitor from the service tool, I can clearly see byte 7 changing state if C1P06 is at 12 volts, but the lamp does not light up

if with my network analyzer I send 80 to byte 7 of my frame with ID 0x100, my lamp lights up

so my reception part works if I send the frame myself!

the tx part of my program also works because I see it in CAN monitor of Service Tool

so everything is good but it doesn't work

I don't understand can you help me

thank you

Pat

3
PLUS+1™ Service Tool / Re: Can Monitor Lag With Fixed Positions
« Last post by Tor on January 14, 2022, 03:03:38 PM »
Thanks acmall,

The case has been reported to the PLUS+1 Developers.


Have a nice weekend
4
Controllers / Re: CAN latch
« Last post by topal on January 13, 2022, 02:15:25 PM »
Hello,

good i come back with good news

I took everything from the start and I found, you were right, it's my can bus analyzer that is not going well, I replaced it with another and it works well

I'm sorry to have wasted so much time on this when everything is ok

thank you

Pat
5
PLUS+1™ Service Tool / Re: Can Monitor Lag With Fixed Positions
« Last post by acmall on January 13, 2022, 02:08:19 PM »
I have sent a report to the help desk as requested.
6
PLUS+1™ Service Tool / Re: Can Monitor Lag With Fixed Positions
« Last post by Tor on January 13, 2022, 11:53:09 AM »
Hello,

Can you please report this issue to the PLUS+1 Helpdesk? https://danfoss.secure.force.com/dpscustomersupport
Or using the support link in the PLUS+1 Tool you are using. It's found in the drop down list Help -> Support -> PLUS+1 Support Web Page
If you are able to record a small video showing the issue, and what you are doing, it would be very helpful for the developers.

Thanks
7
PLUS+1™ Service Tool / Re: Can Monitor Lag With Fixed Positions
« Last post by G30RG3 on January 13, 2022, 09:25:06 AM »
Same here... went back to Canking
8
PLUS+1™ Service Tool / Can Monitor Lag With Fixed Positions
« Last post by acmall on January 12, 2022, 11:30:41 AM »
Is anyone else seeing a bad lag issue with the CAN Monitor built into Service Tool when it is set to display in fixed positions? It appears to have been introduced with version 12.1 and affects all versions since.

You can see this when you switch to fixed positions the message display starts to lag. The display is getting updated for each received message but it takes several seconds to display one seconds worth of updates. When a value in a message changes it takes several seconds for the change to update on the monitor.

If you leave it set to fixed positions for a couple of minutes then switch fixed positions off it accelerates through the messages to catch up, that is several seconds worth of messages get displayed in under a second until the time stamp catches up.

It feels like the messages are not being retrieved from the buffer fast enough for display when set to fixed positions then when fixed positions is switched off it is able to run through the buffer quickly and catch up.
9
Controllers / Re: CAN latch
« Last post by acmall on January 12, 2022, 09:12:07 AM »
Quote
to operate for program did you modify CAN1 to CAN0?

I tested it as is on CAN_1. Have you been able to verify that you don't have a fault on the CAN Line?  You can use the Service Tool to check if the controller is showing any CAN faults by adding logs for: -
  • CAN[1].BusOff
  • CAN[1].ErrorPassive
  • CAN[1].Overflow
10
Controllers / Re: CAN latch
« Last post by Neil on January 12, 2022, 08:07:48 AM »
^ As per hardware file previously mentioned.
Also noted that your raising transmission edge to TX the data isn't connected to the pending output for uniformed transmission, this is mentioned in the help manual (and + not "pending").
I would tend to connect the input pin Cp106 to drive a simple bool switch with a true and false (just for a bit of logic) then pass the output to the encode, rather than a straight pass through.
Pages: [1] 2 3 ... 10