PLUS+1 Hardware > PLUS+1 Compliant Hardware

EMD Speed Sensor

(1/4) > >>

Has anyone here tried the new Sauer EMD speed sensor yet?  I am not a Plus+1 pro so I may be missing something, however this is supposed to be able to be CAN/Pulse/Quad configurable.. which using the service tool expansion pack they provide makes that easy enough.. but I have hooked this up via CAN and I can not seem to get a steady RPM reading using the EMD_CAN compliance block.  Sauer since then has basically told me to set the EMD to pulse and have it set to 180 pulses per revolution.  So I set the sensor to pulse pick up and set it to 180ppr, then use a standard Freq to RPM function block, and again I get jumpy readings all over the place.  Filtering the signal did not seem to help much.  IT is a pull up/pull down sensor so I have my pinconfig0 set to 3.  According to the Input Config manual I should use Pinconfig0 Set @ 3 and Pinconfig1 Set @ 0.  Looking for some help.  I have used standard Danfoss EM speed sensors with zero problem... so this new sensor which I would think is meant to be better and nicer to work with, has caused some curveballs.

I have not yet tried this sensor, but is sounds a bit like the input is setup wrong.
This is your setup:
PinConfig0 = 3 = DigIn: Activated w/ Supply Voltage (Pull Down/Pull Up)
PinConfig1 = 0 = 0 - 5.26 V (mid range).

What happens if you use this setup?
PinConfig0 = (0) = DigIn: Activated w/ 5 V - Supply Voltage (No Pull Down/Pull Up)
PinConfig1 = 0 = 0 - 5.26 V (mid range).

regards Jakob

Hello Jakob,
I have tinkered with the configuration of the input.. and it essentially shuts down any reading.  I do not recall the exact result of doing a pinconfig 0 = 0, I will re-try at some point.  However according to the EMD tech.  This is a 'push/pull output' sensor.. I take that as a pull up/pull down.  I have taken a snapshot of the page in the book and attached.

A push/pull output forces the output signal to be either high or low, so if this is the case. A pull up/down resistance load should not be necessary.
But it shouldn't shut down the output either, so I don't understand why your readings fail.
Also, if the CAN signal output is jumpy, then maybe its the sensor that's the problem.

Are you getting the readout from the servicetool or a display?

Do you have an oscilloscope available to shed some light on whats going on with your voltage output?

Hello Jakob,
Unfortunately I do not have an oscilloscope available.  Besides that of which comes on the service tool.
I initially had a DP200 reading my EMD readout but when it got all jumpy, I just made the program using an MC024-10 and monitored the EMD reading on the service tool with check points.  I have spoken with Sauer and they have since admitted there is some issues with using this EMD sensor with the pulse mode.  That I should take sample counts and filter them, etc.. which is bizarre to me to put a sensor on the market that isn't accurate.  They were surprised to hear I am having issues with the EMD_CAN compliance block, however the Plus+1 HelpDesk in the USA also got the same results I did so I know I am not a complete fool.


[0] Message Index

[#] Next page

Go to full version