Recent Posts

Pages: 1 ... 8 9 [10]

There are a few setup issues in the POU.
The first is that the POU inputs and outputs weren't actually being used, so they have to be connected up.
The second issue is that the GUIDE graphical code can't interface to a Double type, so that has to be converted before it is handed over to GUIDE.

---POU code start
double radians_lat;
Bytes_to_Radians(byte_array, &radians_lat);
*radians = (int32_t)radians_lat;
---POU code end

Return value of ~3.034 or just 3 when I run it in the debugger.
This should at least let you continue then with the rest of the conversions

The debugger can be pretty handy for c code, I often set the True constant next to the POU as a break point, and then just step through the code. This will also let you see some of the local variables in your c code to find any issues. (When stepping through the C file, the Local Variables are in the main GUIDE window in the bottom dock)

PLUS+1 Autonomous Control Library / CanOpen (REAL64) GNSS messages with C Code POU
« Last post by mfaber on March 31, 2023, 12:13:07 AM »
Hi, all. I am trying to integrate a GNSS receiver with CanOpen interface to Plus1. The Latitude, Longitude and heading values are received with CanOpen as a 8 byte hex array. This hex array needs to be converted to a Real64 floating number using IEEE754 system in order to make sense of it. (in radians). Then it can be converted to degrees and then to a S32 integer in order to be useful in guide. I am using C Code POU's to do this. However, I am not very experienced with POU's in Guide so I am having a bit of trouble. I have written an algorithm in C that converts a hex array to a Real64 floating point number. I know this code works because I have tested it independent of Guide. When I test it in Guide however, I am consistently getting 0 on the output from the POU.

During this initial testing the output is a Real64 number which I know Guide cannot work with, but I have made sure that the hex array will correspond to a floating point number larger than 0 so at least the numbers before the decimal point can be displayed. Once this is working then I can refine the code (or add another POU) to do the next steps such as convert to integer accurately.

Can anybody with some experience using C code in POU's have a look over how I have set up the POU and let me know what I have done wrong or missed out? Or anything else you can see that is not correct? Attached is the P1P file.

PLUS+1 Compliant Hardware / Re: JS1H - Digi out
« Last post by magitec on March 29, 2023, 06:46:14 PM »
Perfect thank you. just a few other questions i'm using the PMW output for a 12v reversible output to control a 12v actuator forward is 0 - 12v and then backwards is 12 - 0v which PID file do i require for setting up the limits / proportional control scale.

again thank you, its not something i have used before, i do have the correct CG150-2 cable
PLUS+1 Compliant Hardware / Re: JS1H - Digi out
« Last post by FluidPowerTom on March 29, 2023, 06:09:16 PM »
It looks like it's a yes on all accounts
PLUS+1 Compliant Hardware / JS1H - Digi out
« Last post by magitec on March 29, 2023, 05:26:57 PM »

I have a JS1H with 2 buttons, one on the top and one on the shaft (OP present) on the wiring pinout i have on the black connector a Dig out 1 and Dig out 2.
 i am feeding 12v to pin 2 (pwr 1)  and gnd to pin 1. on the grey connector.
  • So do the dig out 1 and 2 output 12v+ when the button is pressed?
  • do i also need to add 12v to Pwr 2, Pwr 3 and Pwr 4 too?

many thanks.
Displays / Re: DM430 new hardware file
« Last post by Tor on March 29, 2023, 10:57:47 AM »

We got some question about this HWD.
Due to some issues the HWD was pulled back from the PLUS+1 Update Center. I don't have any information when this will be released again.

I'm sorry about that.
Controllers / SC050_C1P46_Status_128_Problem
« Last post by macbahi on March 28, 2023, 04:01:23 PM »

Any controller I use (Sc024 or SC050) to set ON coil using digital output as C1P46 to controller give me error C1P46 status=128 as showing in picture.
I must to reset the controller even though the output was set off. And the current was correct around 1,4A.
The error occurring after a few minutes that everything was working fine. Sometimes the error appears in a little time and sometimes more time.
Coil is sun 770-214  14V  8.9Ohm   and DIN connector S18209TC411.

Please where is the problem?

Thank you very much
With best regards
PLUS+1 GUIDE CANKing / Re: Hex Mode
« Last post by FluidPowerTom on March 27, 2023, 05:27:38 PM »
Tor, you're the man.  I wish I'd asked this years ago...

Edit:  Oh wait, never mind.  Okay, I'm actually clicking that 'Options' button, and nothing is coming up.  I tried going on bus with the virtual CG150, and still nothing pops up.

Even so, if I go to the Options dropdown in the main windows and click Global that pops up a window called Program Options.  It really would seem like selecting hexadecimal in that window would change the output window as well.  Why would it only change the window for putting together messages to transmit but not the output window?  I mean the area it's in is Options->Global.  There's nothing about that which makes it look like it's only for the message creation.

Edit 2:  Okay I figured it out.  You have to click to highlight Standard Text Format in that lower part of the window and then click options.  Pretty clunky.  Still I would think that the Options->Global window pop up would do the same thing.
Controllers / SC050-120 Safety Layer Issue
« Last post by acmall on March 27, 2023, 03:27:21 PM »
I am getting reports of an intermittent issue on a SC050-120 with a Safety Layer Failure. The SafetyLayer.Failure signal has bit 4 set. I can't find any information on this other than the description of ISR Monitor Error, I am guessing ISR stands for Interrupt Service Routine. It is mostly happening at power on and needs a power cycle to clear.

Has anyone seen this before?

General controls / Re: Error 448
« Last post by Daan on March 27, 2023, 03:17:57 PM »
Hey mvanwiechem

It was a problem with the permissions of the IT service. I've been working on a virtual computer ever since so I don't have this problem anymore.

Still, thanks for your time!
Pages: 1 ... 8 9 [10]