PLUS+1 Hardware > Controllers

SC050-120 Dig Output Errors

<< < (2/3) > >>

Tor:
Hi Pankaja2020,

I had a talk with a colleague of mine, and found out there is a problem with these outputs. Especially if you have a capacitor connected. This will give a voltage on the output pin when the DigOut is off, which cause the problem.   I'm not saying this is the issue you have, but there have been some cases coming in to the PLUS+1 Helpdesk about this.

One solution can be to just disable the output for a short period when the DigOut is shut off. (See the quick and simple code I did).
When the DigOut goes low, a negative transition. Disable the monitoring for 1-2 sec.

This output, DisableOutputSafetyMonitoring, was added to the HWD file pretty recent. So if you don't see it, please update the HWD file and the template. If you don't want to update the template, you can add the signal yourself, but read the API before you do it.

Have a nice day.

Pankaj2020:
Hi Tor,

Thanks for you help.

Do you know which version of 'hwd' we should be using? We are using 70156325v210 which was latest.

Thanks,
Pankaj

Tor:
Hi,

The 70156325v210 seems to be the latest SC050-120 HWD.

Good Luck

Pankaj2020:
Hi Tor,

Nope this solution doesn't help.

Still problem & as someone mentioned above Its totally random & goes away with Power cycle.

Pankaj

TheTurfDude:
For our situation we learned that it was a safety layer failure due to high frequencies registering on input pins. After trying all recommended solutions and having unsuccessful results we removed all SC050 controllers from our equipment and replaced with MC050-110's. We have never had issues with the MC050's. We chose to use the SC050 controller in hopes of someday attaining SIL2 certification. After all the problems we had with the SC we reverted back to the MC controllers and haven't looked back.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version