PLUS+1 Hardware > Controllers

SC050-120 Dig Output Errors

(1/3) > >>

Hello all,

I'm having an issue on a SC050-120 where I keep getting a 136 status on the digital outputs when an output is turned on. The output gets the signal to turn on but .Digfeedback tells me the output is not on.

According to the status information in the API document, 136 tells me there is a overload (a short) and the internal voltage is out of range. When the output is turned on the status becomes 128, which tells me the internal voltage is out of range. When the controller is first powered up, some of the outputs jump to a 128 status without being commanded, while others will stay at 0 status until I give them an on command, then they error.

I believe this is a wiring problem as I'm getting the same issue on 2 new controllers, however it is happening on a range out outputs, including running coils and running relays. The multi-function outputs work ok.

Any help on what to look for in my wiring harness that could be breaking these SC controllers?

I ran into something similar when I used the outputs of a controller to drive proportional valves that were wired in parallel to a override switch.  Transient voltage on the output put the pins in overload, especially when you would de-energize the valve coil with the override switch and the controller tried to take control.

Diodes on your outputs to stop feedback would probably do the trick for you, if you cannot find the source.  On my application, I put a block of code to keep the output @ 0 when a overload was detected.  Good luck...

Correction to my previous post. This is a Safety FET issue that is being triggered without good reason. There is no short circuit but the FETs are triggered on both dig inputs and multi-function outputs very easily.

Anything I can do to stop them triggering in the software?


Did you ever resolve this issue? I am running 7, SC050-120 controllers on a new application and the exact thing you explained is beginning to be a problem for myself. I am running the latest HWD for the SC050-120 (70156324v180.sys) and I have the "DisableSafeFet" signal set to false on all digouts. It happens at complete random, when the output is on I get a status code: 136. When the output is turned off the status code: 128. After a brief power cycle the problem goes away for a while.

Please note that the secondary processor is running the same HWD file as the primary.


Any help related to this problem?

I am also facing exact same issue with these controller for Dig output.


[0] Message Index

[#] Next page

Go to full version