Author Topic: Error code (538)  (Read 5241 times)

Offline choongKi

  • PLUS+1 User
  • **
  • Posts: 5
  • Karma: +0/-0
Error code (538)
« on: November 02, 2015, 09:55:10 AM »
Dear. sir

I’d like to ask you about some errors when I was downloading Service Tool.

A controller is MC050-110(1130954) and it’s a new one.

At first try, the controller is successfully connected with the Service Tool.
I got the error (Error: 538) as the attached picture when I was almost done downloading Hex File.
I’m sure it didn’t make any problem connecting the controller.

After the error, the LED of the controller is turned into red at the same time green is flickering.
The controller was disconnected with Service Tool.

I turned the controller off and on again and tried to connect with CAN.
But it’s still disconnected with Service Tool. But once in a while, green is turned on it changes to be connected.

PLUS+1 GUIDE is 7.1.10 and Service Tool is 7.0.6.

What makes this problem?
Is there any way that I can fix it?

Offline Loader

  • PLUS+1 Expert
  • ****
  • Posts: 50
  • Karma: +2/-0
  • If something can go wrong, it will!
Re: Error code (538)
« Reply #1 on: November 02, 2015, 02:31:58 PM »
Hi ChoongKi
you can try to do "Communication/Recover ECU". In many cases it has resumed a "dead" controller!  ;)
Bye

Offline Daniel

  • PLUS+1 Expert
  • ****
  • Posts: 74
  • Karma: +6/-0
Re: Error code (538)
« Reply #2 on: November 03, 2015, 08:47:52 AM »
Hi

It can also be that the baudrate in the downloaded application is different from the baudrate in the previously downloaded application. This would make the Service tool not finding the controller after the download as Service tool is set to the "old" baudrate. You may try to change the baudrate to something else in the list in Service tool and see if that helps.

Best Regards
Daniel
PLUS+1® Help Desk Team