PLUS+1™ Software > Sub System Applications

Flow Meter Integration

<< < (3/4) > >>

Fitzsimmons Hydraulics:
I'm seeing on my data sheet 10kHz as well. I've since been able to get the flowmeter working. It was a grounding issue. Now I've grounded the flowmeter to the IX and it's seeing a frequency and outputting a flow value to the display.

We hooked up a 90 series pump and the display was showing max flow. (35gpm, I believe 55cc) The service took freq signal value reads about 120-130 and flutters around 31-36 gpm as a result. I assume this means 120-130Hz. Problem now is, when we destroke the pump the flow value reads 0. Service tool reads 0 for freq as well, so I don't think there's an error in calculations. The pump is not in neutral when this happens - it is still flowing, the signal is simply zeroed out once the frequency signal crosses some lower threshold. I have tried some different pin configurations and the only one that accepts the signal is pinconfig0=2 pinconfig1=1 for pull down and low range voltage.

If I had to guess, this must be what oiltronic was talking about. Frequencies which would be lower than 60hz don't appear to be registering. I will try to use the period input instead. Thanks all for the input, back to the test bench for now!

BRIan:
It will measure lower frequencies than 60 Hz (provided the sensor output doesn't also drop too low).
The problem is the FREQ signal is an Integer and therefore is limited in it's resolution.
As a norm when the pulses per rev or the rpm are low, I use the PER signal and as long as you are careful with maths you can get perfectly adequate accuracy.

Neil:
Hi Guys,

I'm coming in late on this one, have you checked the voltage at the pin and change .PinConfig1: to suit the voltage range?

regards Neil

Fitzsimmons Hydraulics:
Yes, its a low voltage signal. It's picking up the signal now. I changed my program from using the freq to using per, and it works just like freq did. High flow pumps are ok, and are pretty accurate, but for some reason low flow just doesn't register. I'm going to do more testing and come back to this at a later date. I think it's possible now that the internal calculations are going out of range, even with a U32. What happens when a value goes out of range, anyways? Does it drop out to zero, or does it stick at the max bit value?

oiltronic:
"Out of range" integer calculations typically overflow and wrap around again, or in other words the result of the calculation is clipped to the number of bits at the output.  It helps to understand binary, or how microprocessors do arithmetic.

If there's ever a risk of overflow, despite what the "normal" operating conditions should be,  always use the "capped" version of the arithmetic operator which limits the output to the highest value of the data type.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version