Author Topic: Programming older controllers  (Read 3003 times)

Offline Marbek_Elektronik

  • PLUS+1 Guru
  • *****
  • Posts: 315
  • Karma: +7/-0
    • Marbek Elektronik
Programming older controllers
« on: January 24, 2013, 09:17:07 AM »
Hi,
my customer gives me a controller, which was programmed in 2008.
Now I want to update the software. The update is build with new Guide 6.0.8.
Newer controllers from 2012 have newer fimrware (OS).

Is it better to update the OS of the controller to the newest OS and then program the updated software?
Or is it better to update only the software?

Which case could be complicated?

Thanks for answer,
Bernd
Marbek Elektronik, Dipl.-Ing. Bernd Konrad
Dienstleistung, Entwicklung, Herstellung

radioact

  • Guest
Re: Programming older controllers
« Reply #1 on: March 18, 2013, 06:51:26 PM »
Simply program the controller with the new image and the "OS" will be updated automatically. You will likely see a message about the OS version mismatch, but just hit ignore. As far as I know you can not just update the OS of a controller, it is done when you program with an LHX image that was built with a newer HWD file.

Tyler

Offline Marbek_Elektronik

  • PLUS+1 Guru
  • *****
  • Posts: 315
  • Karma: +7/-0
    • Marbek Elektronik
Re: Programming older controllers
« Reply #2 on: April 23, 2013, 01:33:31 PM »
where do I get older *hwd files?
Because I want to look install them to look in the older API-files related to the OS of the old controllers
and the old software, I have to work on.
I am not allowed to use the actual *hwd file,
because there may bei errors. (Never change a running system....)
Marbek Elektronik, Dipl.-Ing. Bernd Konrad
Dienstleistung, Entwicklung, Herstellung

Offline Neil

  • PLUS+1 Expert
  • ****
  • Posts: 88
  • Karma: +1/-0
Re: Programming older controllers
« Reply #3 on: April 23, 2013, 09:38:31 PM »
I would have thought they would be here, but they are not?

http://www.sauer-danfoss.com/Products/ProductArchive/index.htm

What year of .PAC file are you after or what specific API, I may have a copy to send you.

regards Neil