PLUS+1 User Forum

PLUS+1™ Tools => PLUS+1™ GUIDE => Topic started by: Mike AA on October 17, 2016, 02:03:46 PM

Title: Compile Error on START of compile
Post by: Mike AA on October 17, 2016, 02:03:46 PM
After upgrading to Plus+1 Guide 8.1.1.912 I have randomly been getting this error when I start to compile my program.

Can't open file for write ->
C:\Plus1GuidePrograms\MT3500System\MC50_18T.scs

I have to click ok 6 times to clear then when done compiling the error comes up again, ok 6 times again to clear the error.

I get the same error if I try to save my project. Sometimes I can simply exit Plus+1Guide and restart it and it will compile but I will have lost everything I just changed.

Any ideas? I searched in the forums and only came up with one post with nothing to actually cover what I am seeing.

Thanks,
Mike
Title: Re: Compile Error on START of compile
Post by: FluidPowerTom on October 17, 2016, 05:15:31 PM
Is that file or perhaps your .p1p or .p1x file set to read only?
Title: Re: Compile Error on START of compile
Post by: Mike AA on October 17, 2016, 07:14:16 PM
I restarted the computer and reloaded the program without issue. I have now had it happen to me 4 times in the last month or so. I haven't changed any read-only parameters. I accessed the exact same file and did everything the same this morning as I had done for the last 2 days with the same file. I was connected remotely to the telematics before the issue, during and again after restarting with no changes to that also. Not sure what it is but I will keep watching to see if it is only this program or if any of my other programs do the same things.

Thanks,
Mike
Title: Re: Compile Error on START of compile
Post by: Nilla on October 19, 2016, 03:05:11 PM
Hi Mikeaa12!

If it's possible for you to send me your application in .P1P-format to plus+1helpdesk@danfoss.com I will be happy to take a look at it and see if I can reproduce your issue!

Best regards
Nilla
PLUS+1 Helpdesk team
Title: Re: Compile Error on START of compile
Post by: Mike AA on October 19, 2016, 03:52:02 PM
Nilla,

I sent the file as requested and also attached the picture above for reference again.

Thanks for the help
Mike
Title: Re: Compile Error on START of compile
Post by: Nilla on October 20, 2016, 10:05:11 AM
Hi Mike!

It is received and I will take a look at it now.

Best regards
Nilla
PLUS+1 Helpdesk team