PLUS+1 User Forum

PLUS+1™ Software => General controls => Topic started by: PatrickS on February 02, 2021, 03:16:37 PM

Title: Oscillator Min Period? [Resolved]
Post by: PatrickS on February 02, 2021, 03:16:37 PM
I was working on setting up some counters to count up to 1000 over a given time. I'm trying to accomplish this be hooking up oscillators with 1ms on and a given period into a Loop Counter.
I noticed that all my counters were finishing at the same time even if their input oscillators had different periods. Trying to look into it further, I put a Measure Period on each of my oscillators and they all report 50 ms, instead of the expected 2ms, 5ms, and 10ms.
I see in the manual it says that an Oscillator has minimum period of 2 x loop time, but shouldn't the loop time be less than 25 ms? I thought loop time would be 1/72MHz.
Title: Re: Oscillator Min Period?
Post by: acmall on February 03, 2021, 12:35:56 PM
Check the value set for ExecTimeOut (Inputs-OS).

You can check the actual loop time in the Service Tool by adding a standard log for OS.ExecTime

I think the minimum loop time will depend on the complexity of the software and how many instructions the processor has it execute each loop.

Title: Re: Oscillator Min Period?
Post by: PatrickS on February 03, 2021, 04:47:19 PM
Oh ok, thanks.
I would like to check my loop time but not sure how to do so. Are you saying that i can just put a checkpoint on OS.ExecTime and the output of that is my loop time?
Title: Re: Oscillator Min Period?
Post by: acmall on February 03, 2021, 05:26:29 PM

You should not need to add a Checkpoint. Connect with the Service Tool and add a standard log, select the ECU and scroll down through the available signals, you should find OS.ExecTime which is your loop time.