Author Topic: MC024-118 red & green LED flashing  (Read 1593 times)

Offline LouisGroen

  • PLUS+1 Developer
  • ***
  • Posts: 20
  • Karma: +1/-0
MC024-118 red & green LED flashing
« on: April 04, 2020, 06:57:50 AM »
Good day,

I recently uploaded a file onto a MC024-118, which caused the download to fail and now I have the red and green led constantly flashing. The program I was downloading had some data logging functionality in it. As a back story, I had some issues with the data logging at first, where it would cause the service tool upload to fail and lose communications to the controller.

I did some digging through the code and found a discrepancy in the way I allocated the signals on the "Define APPLog" page. This now being sorted, I loaded this program onto a different MC024-118 and everything works perfect.

Basically I have two questions:
Is it even possible that this is what caused the error?
And now I have the one controller which does not want to connect to the service tool at all, with the red and green led constantly flashing. Does anyone have some insight on resolving this issue?

Thanks
Mechanical Engineer
Bird Machines (Pty) Ltd

Offline Tor

  • Administrator
  • PLUS+1 Guru
  • *
  • Posts: 146
  • Karma: +11/-1
Re: MC024-118 red & green LED flashing
« Reply #1 on: April 06, 2020, 09:20:30 AM »
Hi Louis,

It sounds that the unit is in "Boot Loader" and need a recovery.  You can find the step-by-step instructions on how to do it in the User Manual on page 27, or search for "Recover ECU".  You find the User Manual in the Service Tool Help section, see attached Image.

If the AppLog issue you found caused the problem? I don't know. 
If you are able to recreate the problem by removing your fix an try to download it again, after the "Recovery ECU", to the unit we know. In that case please send this to the plus+1helpdesk@danfoss.com and we have to look at it.

Have a nice day.
Best regards
Tor
PLUS+1 Helpdesk team

Offline Rafal_Typiak

  • PLUS+1 Expert
  • ****
  • Posts: 51
  • Karma: +1/-0
Re: MC024-118 red & green LED flashing
« Reply #2 on: April 07, 2020, 03:58:34 PM »
Hi,
Is your Service Tool (ST) still able to detect your microcontroller? If it's in boolloader mode, it should have a different ID number and the ST should show a description that this unit is in bootloader mode.

Cheers,
Rafa? Typiak

Offline Tor

  • Administrator
  • PLUS+1 Guru
  • *
  • Posts: 146
  • Karma: +11/-1
Re: MC024-118 red & green LED flashing
« Reply #3 on: April 08, 2020, 07:57:53 AM »
Hi,

Thanks Rafal Typiak.
If the ECU is in boot loader it will look like the attached image. The LEDs on the unit also start flashing.
Check the connection and the baudrate if it's not connecting.  Set it to 250k if you have used a different baudrate in your project. The boot loader sets it to default, 250k.
Best regards
Tor
PLUS+1 Helpdesk team