Author Topic: DP720 Failed Downloads  (Read 4812 times)

Offline TheTurfDude

  • PLUS+1 Developer
  • ***
  • Posts: 37
  • Karma: +0/-0
    • Trebro Turf Equipment
DP720 Failed Downloads
« on: April 27, 2017, 09:54:59 PM »
Hello,

We have been installing the WS-503 on our machines for the past 6 months, so far we have 10 devices out there in the world. For the most part they have worked great, downloading software using the WS-503 isn't nearly as fast as using a CG-150 but I understood that from the get go.

We have a variety of Danfoss components on our equipment ranging from DP610, DP610TM, DP720, MC050-110, MC024-20. I have had no issues programming these devices using the Telematics as a gateway (expect for the slow speed) until lately. I am not able to program the DP720, it begins the download and ALWAYS fails. I have seen the "Transfer Exit Failed", "File Transfer Timeout", and "No Answer From ECU" after the failed downloads, and this sends the device into bootloader mode. It is bizarre to me because when I first began using the WS-503 I had no issues programming the DP720, the only problem was it took an hour and a half.

I spoke to the helpdesk, and the telematics group about this and have not got any answers to why this is happening. I did realize that the program size for the DP720 was huge compared to the other display programs we run (I originally used PNG images, creating a 25 MB LHX. I have switched to SVG and have shrunk it down to 11 MB LHX). Even with the smaller LHX file size, the downloads are still failing. Have I changed a setting that I am unaware of? Or, were the successful DP720 downloads just lucky? I have never seen a failed download on any other devices, with a variety of connections (good and bad).

Any ideas?

Thanks,

Jake

Offline Nilla

  • PLUS+1 Guru
  • *****
  • Posts: 253
  • Karma: +13/-0
Re: DP720 Failed Downloads
« Reply #1 on: May 03, 2017, 03:09:11 PM »
Hi Jake!

I know you have been in contact with our telematics team and maybe they've already asked and got answers to these questions but it would help me a lot to get this info;

  • What firmware do you have in your WS403? You will be able to see it in the Remote connection status window when you are connected to your device, see attached picture.
  • What version of PLUS+1 Service tool driver are you running? Can be found by clicking on About in the PLUS+1 Remote connection dialog
  • What version of Service tool are you running?

Best regards
Nilla
PLUS+1 Helpdesk


Offline TheTurfDude

  • PLUS+1 Developer
  • ***
  • Posts: 37
  • Karma: +0/-0
    • Trebro Turf Equipment
Re: DP720 Failed Downloads
« Reply #2 on: May 03, 2017, 04:24:52 PM »
Hi Nilla,

Thank you for the reply, I truly appreciate it. Here is the info about the firmware, drivers, and service tool versions:

FW file: Danfoss WS503_0203n_1201.FwBin
Service Tool Driver: WS_Danfoss_Telematics_Drivers_1013
Service Tool: 9.0.8

If you like, I would be happy send the DP720 P1P file along with the DOD for the WS503. My email is jbies@trebro.com, if you reach me via email I will reply with the P1P and DOD.

Thanks again,

Jake