Author Topic: Error CAN Network  (Read 3322 times)

Maxim

  • Guest
Error CAN Network
« on: May 29, 2013, 01:55:38 PM »
Hello,

I'm setting up a program to communicate between display and controller (DP250 and MC024-018) using a CAN-network.
To do so, I've imported a receiver and a transmitting block both display and controller.


The error page gives me error 21, saying there is no output connected.
ID, mask and port are all connected.



This is the only error keeping me from a working setup.
So far this forum has been very helpful!

Maxim.

Offline hproffitt

  • PLUS+1 Developer
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: Error CAN Network
« Reply #1 on: May 29, 2013, 03:01:37 PM »
You have the same error for both your Rx and Tx CAN blocks.  Are you sure you have the "Port" going to the 'Port' wire on the CAN0 bus?

The coordinates of the error on the Rx page is (158,218); when you put your cursor at the location, what is it touching?  I assume it is going to be your port wire.

Maxim

  • Guest
Re: Error CAN Network
« Reply #2 on: May 29, 2013, 03:10:08 PM »
Yes, the error takes me to the port wire..
These are connected to the correct wire, and goes to the CAN_0 bus on my main page.
« Last Edit: May 29, 2013, 08:14:10 PM by Maxim »

Brian Bandura

  • Guest
Re: Error CAN Network
« Reply #3 on: June 27, 2013, 11:56:24 PM »
If you press "V" (View)  you should be able to trace that port all the way back to your configuration, as in the pic I attached.

Also, the component you show in the second screen capture isn't connected. Thats what the red X's are...

Last thing, whenyou move the yellow ports, if you press F8 as you have it in move, it will rotate 180 degrees, F9 does 90 degrees, but doesn't reverse the label.

regards,

brian