Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Displays / DM1000 Solution
« Last post by F.M.Elettromeccanica on September 15, 2021, 07:03:07 PM »
Hi Gurus,i need carry out a very important project for a machine guidance system with GNSS, I am considering, among other options, to use DM1000. I am very clear about how to proceed to have all the communications I need available (NMEA, CANbus Sensors etc.). What I miss to understand, however, is how to import, and read from them, csv, txt, landXML and possibly DWG files. Is there any expert who can tell me if it is possible to do this with DM1000 or 1200? Projects will be usually available on an usb stick.
22
PLUS+1™ Service Tool / Re: Do Checkpoints increase CAN traffic?
« Last post by Mike on September 15, 2021, 05:19:28 PM »
Just an FYI on a ticket response I had submitted for a similar question:

Yes, it is my understanding the Checkpoints do have an impact on the overall Rom usage as well as RAM used during run time.
Also if the signal is selected by a PLUS+1 Service Tool diagnostic page this will impact CAN bus load as long as the signal is actively being monitored.

It has been my understanding setting the Advanced Checkpoints to False does remove them from the compiled code.
23
Controllers / Re: Stepper using
« Last post by pinias on September 10, 2021, 01:59:35 AM »
Hey Macbahi,

not really, I tried but it is not accurate, the danfoss outputs 12 vdc or source power so no way to stay at 5V without external analog devices.

you can set like an oscillator to change states but the output does not respond that fast.

if you want to use a danfoss device with a stepper I recommend to use a stepper with CANopen, that will work and a stepper with microsteps will do the job better. thta was my fix for that.

I hope this helps

Regards
24
PLUS+1™ News / PLUS+1 now! for Distributors Q4
« Last post by ToddT on September 09, 2021, 08:41:26 PM »
Is this event going to be held soon.
I cannot find any current reference to this training event taking place.
I am interested in gaining exposure from Danfoss about Best Practices, case studies and lessons learned.
The current global situation has left me feeling a little isolated and lacking in input/experiences of others in this field.
25
Controllers / Stepper using
« Last post by macbahi on September 09, 2021, 04:07:50 PM »
Hi!!,

Please is't possible to use any danfoss controllers to drive a stepper.

Does anybody using a stepper with danfoss controller in the past

thanks
26
PLUS+1™ News / Re: PLUS+1 GUIDE and Service Tool 2021.1 is released
« Last post by Tor on September 06, 2021, 03:41:39 PM »
Hello,

A "What's New in PLUS+1 2021.1" video has been uploaded to our YouTube channel.

https://www.youtube.com/watch?v=IdKLFMZuCFg&t

Enjoy!
And don't forget to subscribe.
27
Communication / Re: Transmit and receive custom j1939 PGNs SPNs
« Last post by SJ Industries on September 03, 2021, 09:28:41 AM »
Hi Tom thanks for your help.
I had the source addresses correct earlier. 32 is the node for service tool for main layer, 33 for the safety layer. I made new source addresses for both the screen and the control. But it was your reference to proprietary A and B that solved it. I knew I was using a proprietary message and couldn't work out the changes required. but up until you called them A and B, I googled them and realised I should have been using FFxx instead of EFxx.

J1939 info is a joke. Then every supplier and manufacturer calling certain aspects by slightly different names is a nightmare  to try and navigate for a beginner. 

I have it talking now. And some of it even works.

Thanks again
28
PLUS+1™ Service Tool / Re: UNexpected disconnects
« Last post by FluidPowerTom on September 02, 2021, 05:22:38 PM »
I actually did have an issue yesterday where I was all plugged in and wired up, but when I powered the MC on it did not connect.  It had been connecting earlier that day, and the Service Tool had been left on.  I unplugged and plugged the USB (CG-150) back in, and that made it connect.
29
PLUS+1™ Service Tool / UNexpected disconnects
« Last post by G30RG3 on September 02, 2021, 09:51:30 AM »
Hi,

Am I alone in getting disconnects with the 2021.1.5 version of the service tool and a CG150-2 gateway?
I'm only able to reconnect after disconnecting the USB for a few seconds and letting the PC re-detect the gateway.

30
Communication / Re: Transmit and receive custom j1939 PGNs SPNs
« Last post by FluidPowerTom on September 01, 2021, 02:22:55 AM »
If 08EF0120 is the message coming from your display then you'll want to make a change to your CAN Rx block in GUIDE.  For CAN ID 08EF0120 the source address is 0x20 (32), and the destination address is 1.  It looks like you've got source address as 242 and destination as 32 in the CAN Rx block, so I think you need to change that.  This particular message is  Proprietary A message which behaves a little differently in that the PDU Specific portion of the PGN is treated as a destination address.  Other PGNs outside of the EFxx range are broadcast type and don't need to be received by a specific destination address.  You might read up on it a little.

If your display really is configured to have the CAN address as 0x20 (32) then you'll want to change the PGN of your CAN Tx block to be 0xEF20, and change the source to something else I guess.

If the above doesn't get you up and running then I'll recommend what I did when I was learning CAN.  Use a CAN monitor program like CAN King that lets you manually send CAN messages over the bus, and just mess around with that.  See if you can find the correct CAN ID for the display or controller to read it.

As a side note I don't recommend using the Proprietary A message.  I'd go with Proprietary B message range because then you can send more than one message.  It's been some years since I really used PowerVision, so I can't offer any more advice there.
Pages: 1 2 [3] 4 5 ... 10