General Discussion > Off topic

OEM controls joystick

(1/2) > >>

Where to start??
I have a HCJS9M15488 with limited documentation and so far no support from OEM controls......using can king I can see that it is in pre operational state   Identifier=0x70A and D0=7F  I tried using the JS6000 HWD file with no luck, so now I am just using canking solo trying to get any kind of responce at this point, if anyone has worked with OEM and has an Idea please let me know.

I use OEM CAN joysticks and find that they conform to the JS6000 hardware block.  I've had no problems.  It could be your addressing.  I use a U8 input to the SA pin and in my case the address is 208.  The manual for the JS6000 hardware block talks about using a hex input.  So I'm not sure what's going on there.  Good Luck.

Making headway, turns out the device address is defined by a resistor on the circuit board allowing up to 10 joysticks on one system. 
Node ID:
72 (0x48) + ID resistor offset
ID resistor allows for 10 values {0 ... 9}
Node ID 127 (0x7f) indicates that the joystick is unable to determine its address from the ID
A CAN joystick can derive its CAN ID from its firmware (a fixed or static address programmed
in flash) or from a CAN bus ID key that is plugged into two quick disconnect terminals on the
CAN joystick or from a board mounted fixed resistor. OEM has designed the CAN joystick with
the CAN bus ID key so that up to 10 nodes of the same joystick can be used in a system.

my node id is 0xA  does this make sense to anyone else??

i am now in operational state, I will try the SJ6000 now,
Thanks dlewis


Is your oem joystick j1939 or can open?
Turns out mine is CANopen so Im not so sure the SJ6000 is going to work for me.

I don't know off hand if it's J1939 or CANopen.  If I had to guess it's J1939.

I notices that I'm using the same series Joystick as the one you are using.  Try using an address of 208 or 209 into the SA port of the hardware block.  If I remember right, OEM uses 208 as their standard.

OEM should be able to tell you what address the Joystick uses. 

Your problem could also be due to a terminating resister in the CAN line.  I chose not to have the resister built into the joystick and supply my own terminating resister to the ends of the CAN line.


[0] Message Index

[#] Next page

Go to full version